Roblox Wiki
Advertisement
Roblox Wiki
For other pages with similar titles, see Roblox (disambiguation).
For a list of tutorials and guides, see Tutorials.

The new logo of Roblox Studio in 2021.

Roblox Studio is a development program developed by Roblox offering an assortment of coding and building tools for developing games for Roblox via Lua.

Roblox Studio was released in 2005 as Roblox Developer's Environment. Roblox staff can download preview releases of the suite. It is currently available for Windows and MacOS for free, but mobile operating systems such as Android and iOS are not supported.

Overview

File

New

This button will create a functional pre-established place. Said place will be accessed through a new Roblox Studio window that will originate. The new game will first off be named as "Place1" before being quickly renamed to "Baseplate" if a player chooses the game's template to be Baseplate, they can choose from many templates, after the game completely loads in the engine. Game settings cannot be altered until a developer publishes the game to Roblox.

It is impossible to save the game to Roblox because it was created without a pre-chosen setting. However, developers can save it as a file or publish it into Roblox by clicking the "Publish to Roblox" button in the File tab. By doing that, the program will orientate the developer to set a name for the game, a description, define who is developing the game, to what genre it applies, and to what devices the game will be playable, although defining the name of the game is the minimum required for this situation. After configuring all of the settings, the developer must click the "Create" button to publish the game. Developers can also overwrite an already existing game by clicking the "Publish to Roblox As" button in the File tab.

  • Open Place - Opens an already existing place on an users computer. Browse to a place, click on it, then click "Open".
  • Close Place - Closes the current open place.
  • Save - Saves the current open place. If the place does not have a definite location on an users computer, it will request a location.
  • Save As - Saves the current open place, but will always request for a location.
  • Publish to Roblox - Clicking this, a user will receive an option to choose to update the place. A user's place on the Roblox site will then be identical to the area on another users workspace.
  • Save Selection as Model - Allows a user to save the currently selected block(s) onto there computer. Requests for location.
  • Publish Selection as Model - Allows a user to publish the currently selected blocks as a free model on the Roblox website, or replace an existing model with there selection.
  • Print - Prints what is displayed on a users screen at a printer of there choice.
  • Print Preview - previews what is displayed on a users screen.
  • Print Setup - Adjust the settings for a users printing from Roblox.
  • Recently accessed places - links to open a users recently opened places.
  • Exit - exits Roblox Studio.

Model

  • Select - Selects a part/model. Note that large parts cannot be moved with this tool.
  • Moves a part/model, but can only move in 6 preset directions.
  • Scale - Resizes parts only. Can only scale in 6 preset directions.
  • Rotate - Rotates a part.
  • Transform - Combines all tools above.
  • Anchor - Disallows an object from being moved by an environmental force.
  • Color - Changes a part to have the color chosen by a user.
  • Material - Changes material of a part.
  • Union - Fuses parts together to create a union part.
  • Negate - Turns the selected part into a NegativePart. When unioned with another part it will subtract from that part and create a union.
  • Separate - Separates union parts.

Surface

  • Rocky - Applies the rocky surface to a facet of a block. The rocky surface does not secure a block to another block.
  • Glue (Deprecated) - Applies the "glue" surface to a facet of a block. The glue surface joins a block to another but will break after a certain amount of stress is applied by a character or explosion unless anchored.
  • Weld - Applies the "weld" surface to a facet of a block. The weld surface joins a block to another and can only be broken by explosions unless anchored.
  • Stud - Applies the "stud" surface to a facet of a block. The stud surface only joins to inlet surfaces. Joints can only be broken by explosions unless anchored.
  • Inlet - Applies the "inlet" surface to a facet of a block. The inlet surface only joins to stud surfaces. Joints can only be broken by explosions unless anchored.
  • Universal - Applies the "universal" surface to a facet of a block. The universal surface joins to both studs and inlets alike. Joints can only be broken by explosions unless anchored.
  • Hinge - Applies the "hinge" surface to a facet of a block. Anything on a hinged surface, except for glued or welded blocks, can rotate freely on the hinge until the joints are broken. Joints can only be broken by explosions unless anchored.
  • Motor - Applies the "motor" surface to a facet of a block. Anything on a motor surface, except for glued or welded blocks, will constantly rotate on the motor until the joints are broken. Joints can only be broken by explosions unless anchored.

Terrain

  • Generate - Generates random terrain. A 'seed' value can be set to generate random terrain.
  • Add - Adds terrain using the brush. While clicking, it adds terrain.
  • Subtract - The same thing with Add, but it deletes terrain when clicking.
  • Paint - Paints terrain into materials.
  • Grow - Like the Add tool, but makes it much smoother.
  • Erode - The same thing with Grow, but it deletes it much smoother.
  • Smooth - Smoothens hard edges. This will create "ridges,' which you can get rid of by using the erode tool.
  • Regions - An easy option to add, copy, paste, delete, select, move, resize, rotate and fill terrain.

Plugins

Plugins are applications that add functions to Roblox Studio.

View

Toolbox

The toolbox is one of the assets to Roblox Studio. The toolbox contains everything you need. From a block to a jet airplane, the toolbox contains everything that users have uploaded to Roblox. In order to use the toolbox, click the toolbox option, then click on the drop-down menu at the top of the toolbox. A user can browse to which category, then which object a user would like to select, then click on the object. The object will then appear in the workspace. In addition, clicking "Inventory" will have categories for publicly made models and decals, as well as models that you have made on your own.

Explorer

The Explorer is an important tool in Roblox Studio when a users place contains complex Hierarchy and multiple models. Upon opening the Explorer, some will find a toolbar that lists the hierarchy of the place. All objects in the place are usually stored within the Workspace.

  • Tree-collapse.png
    ExplorerImageIndex 19.png
    Workspace
    • ExplorerImageIndex 5.png
      Camera
    • ExplorerImageIndex 65.png
      Terrain
  • ExplorerImageIndex 13.png
    Lighting
  • ExplorerImageIndex 21.png
    Players
  • ExplorerImageIndex 70.png
    ReplicatedFirst
  • ExplorerImageIndex 70.png
    ReplicatedStorage
  • ExplorerImageIndex 69.png
    ServerStorage
  • ExplorerImageIndex 46.png
    StarterGui
  • ExplorerImageIndex 20.png
    StarterPack
  • Tree-collapse.png
    ExplorerImageIndex 79.png
    StarterPlayer
    • ExplorerImageIndex 78.png
      StarterCharacterScripts
    • ExplorerImageIndex 78.png
      StarterPlayerScripts
  • ExplorerImageIndex 31.png
    SoundService
  • ExplorerImageIndex 33.png
    Chat

Properties

Opening the menu will allow a user to view/edit the properties of the object they have selected, for example, if a user select a brick, the menu will display the color, material, reflectance value, and transparency value of the brick as well as other properties.

Output

The output menu is where script errors and print messages will show. It will always display the location of the error and what the error is.

Shortcuts

Here are some basic keyboard shortcuts to make your experience quicker and easier.

  • New Place (Ctrl + N) - creates a new place in a new window.
  • Open Place (Ctrl + O) - allows a user to browse to a place on your computer, then open it. To open a place, click this button, browse to the folder there place is in on there computer, click on the place, and click "Open".
  • Save Place (Ctrl + S) - allows you to save the place you currently have open.
  • Select tool (Ctrl + 1) - toggles the select tool.
  • Move tool (Ctrl + 2) - toggles the move tool.
  • Scale tool (Ctrl + 3) - toggles the scale tool.
  • Rotate tool (Ctrl + 4) - toggles the rotate tool.
  • Transform tool (Ctrl + 5) - toggles the transform tool.
  • Cut (Ctrl + X) - Takes the selected object, removes it, and allows it to be pasted into a users workspace infinitely.
  • Copy (Ctrl + C) - Takes the selected object and allows it to be pasted into a users workspace infinitely.
  • Paste (Ctrl + V) - Must have copied or cut before using - Takes the cut/copied object and puts it into the workspace when clicked. Can be used infinitely after copying/cutting.
  • Paste Into (Ctrl + ⇧ Shift + V) - Takes the cut/copied object(s) and inserts it into the selected object.
  • Duplicate (Ctrl + D) - Duplicates whatever is currently selected. This is useful if a user does not want to keep spawn parts and anchor them. Cannot paste objects that have been cut/copied.
  • Undo (Ctrl + Z) - Undos the action a user just performed. The drop-down menu does not serve any purpose.
  • Redo (Ctrl + Y) - Redos the action a user just performed. The drop-down menu does not serve any purpose.
  • Group (Ctrl + G) - Allows a user to group the selected objects and lock the grouping so they can all be selected and moved together at need.
  • Ungroup (Ctrl + U) - Breaks the connection of a selected group of objects.
  • Toggle Collisions (Ctrl + ⇧ Shift + C) - Toggles whether collisions of parts is turned on or off. If it is on, a user will not be able to move parts through other objects.
  • Rotate (Ctrl + R) - Rotates the selected object on a vertical axis.
  • Tilt (Ctrl + T) - Rotates the selected part on a horizontal axis.
  • Move upward (E) - Moves a users camera upwards.
  • Move downward (Q) - Moves a users camera downwards.
  • Union (Ctrl + ⇧ Shift + G) - Unions the selected parts. This fuses them together and creates a UnionOperation.
  • Negate (Ctrl + ⇧ Shift + N) - Negates the selected part(s). This subtracts from other parts and creates a UnionOperation.
  • Separate (Ctrl + ⇧ Shift + U) - Separates the selected union/negated part(s).
  • Local/Global Space (Ctrl + L) - Changes how the currently selected object will move. Global Space will let a user move the object along the world's X-axis, Y-axis, and Z-axis, while Local Space will move along the object's X, Y, or Z-axis.

Keyboard shortcuts can be viewed and changed at any time by going into File > Advanced > Customize Shortcuts.

Test

Whether a user has no scripts or there entire place is scripted, they will want to test it within in the Studio so that players are able to catch and eliminate existing bugs in there game before they actually release there game to the public. There are three options for testing, located in the 'Test' column:

  • Play - Spawns a users character to a spawn location. If there are no spawn locations in the map, the character is spawned in the center of the map.
  • Play Here - Spawns a users character where there camera currently is.
  • Run - The place (scripts, animations, etc.) runs but without the character spawning.

Publishing

Once a user is finished editing and testing there place, they will upload it to Roblox so other users can play it. Go to File > Publish place to Roblox, then follow the steps to get it published. Or if your game is already published, click "Publish to Roblox" here, Depending on the size of a users place and there Internet upload speed, it may take about 5 - 30 seconds or longer for it to get published.

Team Create

Team Create is a feature on Roblox that allows a user to build on Roblox Studio if added to the list by the owner of the game. Team Create is the feature which replaced personal servers. It was released on April 13, 2016. There are colors that change in different personal computers a user uses. But this is not changed in the original computer they use. If a team member selects an object, a colored circle appears in the left side of the object in the Explorer tab. The circle colour depends on the colour of the user.

How to use

To use Team Create, go to the View tab in Roblox Studio, and then click on the Team Create button. If the feature is turned off, click on the green Turn On button. The game must be published in order for team create to be used. When clicked, it will restart Roblox Studio and enable Team Create. Next, type in a username in the box on top of the panel. Once a user invite someone, have them go to the place's page and click on the Edit button. They will then be added to the editing session. A coloured transparent sphere indicates that a user is building in that area.

Group games

Group games have the ability to be used by team create. To enable group games to have team create on, simply turn it on/off. Then, anyone with the Create and edit group games permission can go into team create, regardless if invited or not.

Gallery

Icons

Splash screens

Removed splash screens

Layouts

Advertisement